Website outage
Incident Report for Macabacus
Resolved
This incident was caused by an unexpected failure of a server managed by one of our technology partners. The server has been restored and appears stable. This incident is now resolved.
Posted 4 months ago. Jul 20, 2017 - 11:39 EDT
Monitoring
There is no longer an outage at macabacus.com. We are working with our technology partners to determine the root cause and whether to expect further outages.
Posted 4 months ago. Jul 20, 2017 - 11:28 EDT
Investigating
The macabacus.com website is down for reasons that we and our technology providers are currently investigating. This outage may affect user authentication and thus access to Macabacus software.
Posted 4 months ago. Jul 20, 2017 - 11:25 EDT