Subscription management outage
Incident Report for Macabacus
Resolved
Issues have been resolved. Contact support@macabacus.com with any questions.
Posted almost 2 years ago. May 10, 2016 - 10:19 EDT
Identified
Our subscription management vendor is experiencing a temporary outage that is affecting user authentication and Admin Console operation for some customers.
Posted almost 2 years ago. May 10, 2016 - 09:40 EDT