Website outage
Incident Report for Macabacus
Resolved
The server outage has been determined to be the result of a failed hardware component. The component has been replaced, and no further outages related to this incident are expected.
Posted 11 months ago. Jul 20, 2017 - 13:18 EDT
Investigating
The macabacus.com website is experiencing an outage likely related to the one earlier today. We and our technology partner that manages the server are investigating.
Posted 11 months ago. Jul 20, 2017 - 12:49 EDT