Intermittent website outage

Incident Report for Macabacus

Resolved

This incident has been resolved.
Posted Feb 25, 2020 - 15:58 EST

Update

This incident has been resolved.
Posted Feb 25, 2020 - 15:58 EST

Update

Website performance has improved, but intermittent degradations in performance may occur as we continue to investigate this issue.
Posted Feb 25, 2020 - 14:20 EST

Update

We are continuing to investigate this issue.
Posted Feb 25, 2020 - 10:30 EST

Investigating

We are experiencing intermittent outages affecting our website and user authentication. We are investigating this issue.
Posted Feb 25, 2020 - 09:33 EST
This incident affected: Website, User authentication, and Admin Console.