Authentication and Admin Console Issues
Incident Report for Macabacus
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 23:20 EST
Update
We appreciate your patience. The issue, due to an outage today at Recurly, has been resolved.
Posted Jan 08, 2024 - 18:45 EST
Identified
We are currently investigating as it appears that one of our providers is having intermittent issues impacting the performance of our platform. We will update here as we learn more. Thank you for your patience.
Posted Jan 08, 2024 - 11:08 EST
This incident affected: User authentication, Admin Console, and Recurly.