Website outage
Incident Report for Macabacus
Postmortem

At approximately 9:15 AM EDT this morning, a Macabacus data center experienced a brief Denial of Service attack resulting in approximately 30 minutes of downtime for the website. The attack has been contained, and no services or data were compromised in the attack.

Posted May 04, 2020 - 13:10 EDT

Resolved
This incident has been resolved.
Posted May 04, 2020 - 10:20 EDT
Investigating
We are currently investigating this issue.
Posted May 04, 2020 - 09:22 EDT
This incident affected: Website, User authentication, and Admin Console.