Admin Console Down

Incident Report for Macabacus

Resolved

The issue has been resolved. Service has been restored.
Posted Feb 27, 2025 - 18:11 EST

Investigating

We are currently investigating the issue, and will provide an update shortly.
Posted Feb 27, 2025 - 17:57 EST
This incident affected: Admin Console.